LaTeX export PDF and export word fails, confluence 5.5.2 LaTeX 1.8.3

Using version confluence 5.5.2 LaTeX 1.8.3 inside of confluence the formulas work fine, but every time I try to export them to another format (word or PDF) on the the exported document I get this:

LaTeX Math rendering error (show error message).

With the show error message containing a hyper-link that and no URL?!?

5 answers

1 accepted

This widget could not be displayed.

I was able to fix it by yum install dvipng texlive, rebooting confluence and then going in and pointing to the correct dvipng executabe thanks!

Hello Robert

Would you be so kind to give us more details regarding last part 'going in and pointing to the correct dvipng'. I was able to upgrade Confluence from 3.5.7 - 5.5 , but only problem I have at the moment is with latex plugin. Where we can get version LaTeX 1.8.3 ? Appreciate your help. Thank you.

Regards,

Milan Stakic

LaTeX is a plug in so in confluence just go to * (admin) add-ins and if LaTeX is there it may need to be updated to said version, if not just add it through find new plugins. Other than that I had to do a manual grab of dvipng and texlive, the way to tell is from the command line run: # yum (or apt) install dvipng texlive (of cousre that is assuming your server is *nix and not windows or something else) Also you should have under confluence admin a Latex Math under configuration in the admin list on the left.

Hello

Thanks for prompt feedback.

I managed to find Configure the Latex Plugin, so I suppose that was the place where I need to add path. Trying to find those paths.

Regards,

Milan

Yeah that is under the LaTeX math configuration under "external png Renderer" for us as we use the external one for PDF exports

Hello

It's working now.

Regards,

Milan

This widget could not be displayed.

Hello Robert, there is another thread about this error, where it appears to contain a fix. Maybe it can help in your situation too.

This widget could not be displayed.

Great point we were just asked to switch from debian to redhat and so I have not updated texlive and dvipng. I hope that is the problem. I can only restart confluence in the wee hours so I will update with whether or not this is the problem. Thanks!

This widget could not be displayed.

Unfortuneately that did nothing. I did a yum install dvipng texlive. There is a latex on the new system as well. Any other thoughts?

This widget could not be displayed.
Gonchik Tsymzhitov Community Champion Aug 01, 2018

Hi! 

 

Sorry, I have met with problem in exporting into PDF on 6.10.1 version of Confluence, and  Latex Math version is 3.7.7. 

 

Cheers,

Gonchik Tsymzhitov

Gonchik Tsymzhitov Community Champion Aug 03, 2018

Hi! 

 

I have fix it by writing own solution.

Cheers,

Gonchik

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

294 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you