JUnit Macro not displaying names or failures properly

We have inserted the JUnit macro on to a few of our pages, but have been unable to get it to properly show test results. We have the three tests shown on this page named within the xml, but they are not showing on the test or on the page we inserted this macro onto. And we know for a fact that some of these have failed, but it is not showing the failures. We know it is connecting to the file because when we add a test, it will show a number 4. We have this folder saved to the C: drive of the computer we are running confluence off of.

Here is a screenshot of our setup window.

Junit

3 answers

This widget could not be displayed.

This issue is still occuring. We even created a new subfolder in that junit-tests folder and tested there, it also isn't working.

This widget could not be displayed.

This is still unresolved.

This widget could not be displayed.

This is still unresolved.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

603 views 8 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you