It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issues with editing Excel documents with Office Connector

We have the macro placing the Excel document on a confluence page, it has the edit button where it can open with the Atlassian companion. However when it begins to open up MS Excel it get hit with a "because the file format or file extension is not vald" it could not open.

 

I am using the SAML SSO for Confluence not sure if SSO might be causing the issues. I remember using SSO in another instance of on-prem confluence but didn't have this issue. 

 

Any thoughts would be awesome!

 

1 answer

0 votes

Hello Dan,

Thanks for bringing this to us. Happy to help figure out what's going on here. I just have a few questions for you!

  1. Does this occur with any Excel document on any page in Confluence?
  2. Do you have the same issue with Word and Powerpoint documents too?
  3. Are all users able to replicate the problem across different computers?
  4. What version of Office are you using?
  5. What is your Confluence version?

The error you are encountering is usually a Microsoft issue, and not related to the Companion app. For example:

Based on the information in those articles, can you give the fixes a try and see if it solves your issue?

Thank you!

Regards,

Shannon

@Shannon Spaniol Hi there! 

  1.  Correct any, I have tried multiple excel docs, not just the one my customer made
  2. I have not tried yet
  3. I tried as well, instances are the same level across the board
  4. I have tried Office 365 and Officer 2019
  5. Confluence 6.15.7

Thanks for any help!

 

@Shannon Spaniol I figured it out, we had an F5 blocking it. It is causing issues with the companion app and excel.

Like Shannon Spaniol likes this

Hi Dan,

Thank you for letting me know you were able to solve it! Glad to hear. :) 

Take care, and have a pleasant rest of your week.

Shannon

Hello @Dan

May you please provide details what was wrong in F5 BigIP settings to trigger this "extension" or "mime type" issue with Office files and the way you have fixed it?

Thank you in advance for your help. Yves

I believe it has to do with the encryption and decryption when downloading the file through the F5 - We haven't fixed it yet

@Shannon Spaniol Hi Shannon, have you heard any other similar issues to this? We still have this issue - I know without the F5 as mentioned this issue doesn't exist. 

Hi @Dan,

Thank you for following-up. I haven't seen any other cases about this personally, but I have consulted the rest of the Confluence team. It appears it may have been caused by this bug:

  • CONFSERVER-57593 Edit in App does not work when Confluence is integrated transparent SSO (and 2FA)

This has been fixed as of Confluence 7.2.0. If you're not ready to upgrade, be advised that the workaround in the ticket is only confirmed to work up to version 6.12. In version 6.15, there's a dark feature that can do the same:

Please have a look at that, and let me know if it helps, or if you have any trouble.

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

5,343 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you