Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How to remove a Long-Running Task on Confluence Server?

While attempting to update an app, the task got stuck and stays as a long-running task only displaying the Installing panel on the Manage apps page stuck in "Downloading... Installing..." and preventing further actions.

We are on Confluence server 7.11.1 and I can only find information on how to kill the long-running task on Cloud ( Any advice on how to resolve this on Confluence server is appreciated, thanks.

1 answer

1 accepted

0 votes
Answer accepted
Charlie Misonne
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 17, 2021

Hi Annica,

I'm afraid the only solution is to restart Confluence. Have you tried that yet?

Processes can not be killed separately in Confluence server as there is only 1 system process: the java process.

Thank you Charlie, a restart resolved the issue :)

Like Charlie Misonne likes this

I have encountered the same problem after installing an add-on. We restarted the service and still get the error you described:

A long-running task has been initiated by another user. To avoid conflicts, you will not be able to update apps until this task has completed.


Is there any other way to solve this?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events