Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How do I edit a page properties macro in Confluence template page to include a set list?

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Apr 25, 2023

My team uses a template page in Confluence to write up documentation for completed projects. The template contains a page properties macro. Some of the values in the right column of that page properties macro are set lists. For example, when creating a new page from the template, team members select a product from a list of our product offerings. We have another page that uses the page properties report macro to list high-level details of all completed projects.

Recently the page properties table on our template broke, and team members are no longer able to edit two of the rows in the table.

Here's what the template looks like for team members. Please note, "Product Category" should be another dropdown list, but instead it is an uneditable line of text.

Screenshot 2023-04-25 at 2.20.05 PM.png

I can't figure out what is broken. The second screen shot is what the table looks like in the editor view. Everything in the page properties macro within the template page appears to be formatted in the same way. The methodology row is selected in the screenshot below, but the product category row has the same formatting when it is selected.

Screenshot 2023-04-25 at 2.13.03 PM.png


I've also tried to create a new template page from scratch, but I can't figure out how to set up a predetermined list in the page properties macro on our template page. 

Does anyone know either,

1) What broke and how to fix it, or

2) The specific page element I need to insert in the cells on the right to set up a new pre-determined list?

1 answer

1 accepted

0 votes
Answer accepted
Nicolai Sibler
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Apr 26, 2023

Hi @Sarah_Harvey , welcome to the Community!

That's a strange behaviour you're facing here ... I guess it's probably a bug.

However, this might be worth testing before you open a support ticket:

All three rows with that issue have in common that the names of the variables contain an underline [ _ ].
I'd try to create new variables without the underline.

Once you added the variable, select it, choose List and enter the parameters, separated by commas. (Just like in your screenshot.)

How to add variables differs from Server/Data Center to Cloud. See the documentation for details:

Kind regards,


I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 05, 2023

Thank you, Nicolai! I tried renaming the variables (no underscores this time) and it worked! Those had been in place on our template page for years, so I'm still not sure what caused them to break in the first place... but it's fixed now.


Thank you again!

Like Nicolai Sibler likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events