Has anyone had trouble with inline comments on images in Confluence?

My users are trying to use inline comments on images. The option appears and they are able to fill in the field, but the comment doesn't save. They can save inline comments for selected text. I haven't restarted Confluence yet. Is this possibly an indexing issue?

1 answer

This widget could not be displayed.

Hi Aram,

Which version of Confluence are you on? I'm highlighting an image on my instance, but I don't even get the option to add an inline comment until I select some text.

Kind Regards,
Shannon

I am on 5.8.10. I'll see about getting some screen captures.

Thank you, Aram - can you let me know also which browser this occurs in?

Are you able to tail the Confluence logs and see what error is showing? 

Lastly, does the inline comment appear after doing a hard refresh of the page a few times?

Kind Regards,
Shannon

Delete comment in pic error.png

So this error came up after I tried to delete a comment I just created, before closing the picture window.

When I hard refresh, the comments box is empty.

I haven't been able to tail the logs just yet. Mostly because I don't know what I am looking for, but since I have a screen cap now, and a timestamp, I should be able to detect something.

And I am using Chrome, Firefox, and IE. Just to make sure it wasn't a browser issue.

Hi Aram,

Thank you. The inability to delete the pinned comment is another issue here:

With your screenshot, I can see you're referring to the pinned comments within an attachment. Is this correct?

I can see two issues that seem similar to your problem adding the comments:

However, the first bug doesn't really say under which conditions does this occur, but it does show that you're not alone in this issue.

The 2nd issue refers specifically to anonymous users, but I believe your issue is that all users cannot add comments to attachments? Is this correct? Is it 100% of your attachments as well? Lastly, I've seen a few cases similar to this where after the attachment was reloaded several times, the comment appeared, which is likely to be an indexing issue.

Once you are able to tail your logs and replicate the issue at the same time, we'll be able to see what the actual error is.

Thank you!

Kind Regards,
Shannon 

Hi Shannon,

First of all, thank you for taking the time to help out.

I think I am going to treat this as an indexing issue and rebuild the index this coming weekend. This will be a hard rebuild. I'll keep you posted on the results.

Regards,

Aram

Aram,

Thank you for the update. Just let me know if you have any trouble or make progress!

Kind Regards,
Shannon

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jul 30, 2018 in Confluence

How Manon Soubies-Camy uses Confluence + Trello to organize webinar notes and her knitting stash

@Manon Soubies-Camy is an engineer who has been an avid Atlassian user since 2014. She helps companies of all sizes transform the way they work with the Atlassian stack, including Jira and Confl...

863 views 8 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you