Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,436
Community Members
 
Community Events
168
Community Groups

Group permissions vs User permissions

Hi!

Confluence 7.13.5 Data Center

We have a group which we use to give Users access to certain spaces.

A user is in the group which has 

All - View
Pages - Add
Blog - Add
Comments - Add
Attachments - Add

permissions in a space.

Interestingly, the user is not able to access pages (without restrictions) in the space.

When I add the User with the exact same permissions to the space permissions, He is able to access the pages.

Why does this happen ?

Any hints would be appreciated!

Regards,
Hans

5 answers

2 accepted

0 votes
Answer accepted

Hi!
It turned out, that the reason was a problem with the Sync from the LDAP Directory.
After the User explicitily logged out and logged in again, the Group permissions have been synced and the User was able to access the Space.

Regards, Hans

0 votes
Answer accepted

Could the inaccessible pages be located beneath a page that has view restrictions?

0 votes
Rilwan Ahmed Community Leader Aug 08, 2022

Hi @Hans Pesata ,

  1. Please check if the user is really part of the group or removed for some reason. 
  2. Please reconfirm if the group is added to space permissions  (check space settings --> Space permissions)

Hi!

Yes, I can confirm both.

As described, I had added the user to the group and he immediately tried to access the space, which didnt work. probably because He would have needed to log out and log in again, to get the groups enhanced permissions.

Am I right ?

Thanx & Regards,
Hans

Rilwan Ahmed Community Leader Aug 09, 2022

@Hans Pesata 

Are you using any ldap/Active directory for users and groups sync ? If yes, then you need to wait for the sync to complete. 

If you are using internal directory for user and group management, then just a page refresh will do .

Are you still having the reported issue ? 

Hi!

Exactly this seems to have happened.

Regards,

Hans

Rilwan Ahmed Community Leader Aug 21, 2022

Please accept the answer if this resolved your issue. It would be beneficial for users with similar queries.

@Rilwan Ahmed 

I accepted the logout/login answer from Aug 20th.

Regards, Hans

Like Rilwan Ahmed likes this

HI!

Thanks for Your answers!

Maybe the problem was this:

I had added the user to our group and he immediately tried to access the page.
I think He should have logged in again, to get the permission through the group ?

When I added Him directly to the restriction, it worked without logging in again, because this is action related to the space and not user attribute related.

What do You guys think ?

Regards,
Hans

It is not a bad idea, but Confluence does not work like that.  As soon as you are in a group, it shows.  They are not cached at login.

However, if you are using an external directory for users, there is a sync cycle, so you may not be added into the group immediately, confluence may not recognise the new group until the next sync.

Like Hans Pesata likes this
0 votes

HI @Hans Pesata ,

Just to be sure:

  • Other users in the same group can access the space? 
  • Can a user B with the same configuration (same user groups) access the same space/page?
  • What error message or Confluence page is the user presented with when trying to access the space or any content of that space? Please try with the space homepage. 

That would help figure out your issue. :)

Best, Max

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events