Confluence upgrade caused Pocket Query to break

We upgraded Confluence from 5.8.10 to 5.10.6.  The Pocket Query is now throwing an error on the affected pages.  The error reads "Error rendering macro 'pocketquery' : null".  When reviewing the Pocket Query configuration, everything is showing as "null".  I cannot delete these or add anything new.  When I click the trash can they don't actually delete.  Please advise on how this can be resolved.

Thank you,
Allen

Confluence Error null.png

 

5 answers

I work with Allen.  Here's some additional information.  

We've tried reinstalling PocketQuery, but upon re installation we still see the null queries and database.

 

2016-10-11 10_20_37-PocketQuery Administration - Medseek Confluence.png

We were able to fix the issue.

Here are my notes, incase someone in the future has the same issue.

We deleted all references to pocket query admin inside confluence database bandana table where bandana context = scandio

Then we uninstalled PocketQuery 2.1.2 and reinstalled 2.1.1.

Then we restored from our pocketquery backup.xml

 

Hi everybody,

I'm really sorry, somehow I didn't see this question earlier. Let me guess: you upgraded to Confluence 5.10.6? This is the single Confluence version that has a bug with Bandana:

Atlassian fixed this issue in Confluence 5.10.7 and released that version quite fast. I would consider 5.10.6 not a production version because of that issue.

I worked around this issue in PQ 2.1.1 which is the only version that works with Confluence 5.10.6. You can use this version as long as you're on 5.10.6. But I'd recommend to upgrade to a higher version, since there might soon be more problems with third party add-ons using Bandana.

Also: there is no need to do deletion or import/export. All the data is actually there, even if you see all those nulls. 5.10.6 simply won't allow the add-on to retrieve the data.

Regards, Felix

Hi All, 

 

What was the solution to it? We're on Confluence 5.10.6 and just updated PocketQuery. 

 

Thanks,

Boris 

Please see my answer from Oct 15. If you have Confluence 5.10.6, please use PocketQuery 2.1.1. Otherwise, use 2.1.2. Confluence 5.10.6 has a bug that caused PocketQuery to break.

Thanks. We upgraded to the latest version of Confluence and are fine now. 

The issue got resolved once we upgraded Confluence to 5.10.8

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,227 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you