It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence for Windows: Could not load bootstrap from environment after backup Edited

Dear Community,


I have updated a Confluence installation to 7.3.1 (Server 2016 x64 Datacenter). But after running the Upgrade Wizard, I always end up with the following error that has been discussed 1.000 times before:

"BootstrapException: Unable to bootstrap application: Couldn't save confluence.cfg.xml to D:\Confluence\Confluence Home directory."

Confluence is installed in d:\Confluence\Confluence
Confluence Home Folder ist d:\Confluence\Confluence Home (it contains a space, maybe that's the issue)
The file confluence-init.properties looks like this: confluence.home = D:/Confluence/Confluence Home

The thing is that I checked everything 3 times now:

  • I am installing with the local user "confluence".
  • The user is a member of the local admin group (should have full access anyway)
  • The user owns the whole folder d:\Confluence
  • The user has Full Access set individually to d:\Confluence
  • The user "everyone" has "full access" to d:\Confluence
  • I force-inherited the permissions down into everysubfolder
  • I logged in "confluence and checked if I can edit the confluence.cfg.xml (works)

 

What else can I do?
Please, our whole Knowledge base is down and I am desperate an totally out of ideas what else could be the issue.

Might it be the space in the Home path?

Can anyone help please?

 

 

 

1 answer

Solved, can be closed.

Hi Axel,

I have the same problem...

How did you fixed this ?

Hi Gert,

I realized that with every run of the installation routine, the services had been re-registered to the wrong user accounts, even though I had fixed it.

Once I saw that, I let the setup have it's run, changed the users manually and started the update wizard then, with services running unter the confluence user account.

Hope that helps.

Kind regards
Axel

Hi Alex,

Tx for the tip.

I deleted the Atlassian service (service.bat remove) and reinstalled the service. (service.bat install)

After this action the service runs under the NETWORK SERVICE account.

We changed the permission on the HOME folder so NETWORK SERVICE has read/write access...

Problem solved...

Kind Regards

Gert 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

7,071 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you