Confluence atlas-package does not work as expected

We have a Confluence add on and we are facing problems with quick reload. atlas-package is supposed to do a quick-reload when the instance is already running. Whenever we try to do that, it keeps on doing quick reload several times as seen in the log and instance becomes really really slow to perform any action. As a result, we have to restart our instance altogether. We use standalone instance sometimes but it is not very helpful while debugging the code.

 

Also, several times we have seen that atlas-package will create another instance of confluence. So, we have to kill the PID and then restart the app.

 

Have you seen this issue and do you have any suggestions/information about this?

1 answer

This widget could not be displayed.
Gonchik Tsymzhitov Community Champion Apr 11, 2018

Hi Renuka! 

 

I am using for developing the debugger port 

https://developer.atlassian.com/server/framework/atlassian-sdk/creating-a-remote-debug-target/

 

and for upload use  rest api 

https://developer.atlassian.com/platform/marketplace/registering-apps/

 

May I know, do you really need quick reload? 

 

Cheers,

Gonchik Tsymzhitov

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

515 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you