Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,546
Community Members
 
Community Events
168
Community Groups

Cannot sort columns (intermittent)

I have a Confluence page that displays the results of a Jira filter, but it will not let me sort by column.  The only column that I can currently sort by is Issue Key.  This happens intermittently, but sometimes I can sort by any column.  

I need to sort by Priority, so that the highest priority items appear at the top.  It's frustrating because it sometimes works as expected, but not every time.

The columns are IssueType, Priority, Key, Summary, and Labels.  The problem does not seem to be related to the number of issues, or the number of pages.  (Currently showing all issues on one page.)

The Jira filter does not have a default sort in it, although I have tried setting the default sort to "ORDER BY priority DESC."  That had no result: the Confluence page still worked sometimes, and not others.

Any ideas on how to make the column sort work consistently?

 

1 answer

0 votes
Daniel Ebers Community Leader Aug 15, 2022

Hi @Wade Harshman

welcome to the Atlassian Community!
What me worries a bit is that you say sometimes works and sometimes it just don't.

Can you pinpoint it probably to a specific browser (Chrome, Firefox) or is it working for your colleagues (if given) per any chance?

While you are on Confluence Server it could make sense to have a look into log files if an error is logged there when you try to sort.

Also, I found some information in knowledge base, however I am unsure if this applies when you say it works from time to time:

Is there any pattern you observe when it is not working vs. when the sorting runs through fine?

Regards,
Daniel

That's the part that's confusing me, too.  I'm using Edge.  I have found no pattern, I can simply keep reloading the page and it will works at certain times but not others.  If there's no known issue, I'll just keep an eye on it and see if I can find any root cause.

Daniel Ebers Community Leader Aug 16, 2022

Very strange, indeed. If you have the change to do so, trying a different browser for a shorter moment and/or deleting cache on Edge could help - but you would need to test.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events