It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Adding 'Atlassian Jira' User Directory on Confluence returns HTTP error 404

I was trying to share Jira users with newly-installed Confluence reading this document (https://confluence.atlassian.com/doc/connecting-to-crowd-or-jira-for-user-management-229838465.html#ConnectingtoCrowdorJiraforUserManagement-ConnectingConfluencetoJiraapplicationsforUserManagement), but I'm completely stuck.

 

In the section 'Connecting Confluence to Jira applications for User Management' you can find an instruction saying 'Add a directory and select type 'Atlassian Jira''.

This action should navigate to the Jira setting page (in which you put server URL, application name, application password and so on), but what I see instead is an HTTP 404 error page (like the photo I've attached).

 

Do you think of any possible cause for this problem? I have no idea what I'm supposed to do/check.

 

Some additional information (not sure if they help though):

  • The same action successfully navigates to the setting page if I select other directory types than 'Atlassian Jira'.
  • The base URL for Confluence is added into Jira Whitelist.
  • Jira and Confluence are installed on the same server on AWS.
  • I'm using nginx to deal with http requests.キャプチャ.PNG

2 answers

0 votes

Hey there Ryo!
I recommend starting by checking if your proxy is not causing problems. Even though both instances are in the same server, the request can be tampered with by the proxy.
Here is how to bypass the proxy:

Also, since both instanes are on the same server, it is worth checking this:

Since cookies do not differentiate between port numbers, login can be problematic for instances running on the same server.

Let us hear from you, Ryo. Looking forward to your reply!

Thank you for your reply.

Just a quick report; I tried the second solution but Confluence still shows the same error.

I will soon try the other one and tell you the result.

0 votes

コメントが遅くなってしまい恐れ入ります。language-jaタグを追加いただいたので日本語でも回答します。その後も問題は続いておりますでしょうか。

本件は以下のようなJiraサーバへのディレクトリ設定が表示されず、代わりに404エラーとなってしまうという問題かと思います。

Screen Shot 2019-09-06 at 15.58.25.png

Embedded Crowdのプラグインの機能が正しく動作しているか気になります。

ユニバーサルプラグインマネージャー で同プラグインのモジュールは全て有効になっておりますでしょうか。

Screen Shot 2019-09-06 at 16.01.49.png

また、上記がすべて有効の場合はConfluence のプラグイン キャッシュをクリアする方法 で問題が改善するかお試しいただけますでしょうか。

ご返答いただきありがとうございます。

  • Embedded Crowdのモジュール確認
  • プラグイン キャッシュのクリア

ご教示いただいた上記2つの解決策を試しましたが、同様のエラーが依然発生します。

ひとまず、Diego Canto Rodriguesさんの方法もこれから試してみようと思います。

 

また何かありましたらよろしくお願い致します。

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

269 views 9 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you