Setting up SSH connection

Hello, i've successfully installed Bitbucket Server 4.10 behind nginx. Now i have issues while cloning/pushing repos from my local server. Everytime i do that i am asked for a password. What's wrong?

1 answer

0 votes

Hello Alexander,

Thank you for your inquire.

Well done on installing Bitbucket Server behind nginx.

Regarding on the password request, one possible cause could be you are not adding the ssh protocol to the git clone command:

git clone git@localhost:7999/proj/repository.git (causing password request)
 
git clone ssh://git@localhost:7999/proj/repository.git (suggestion)

Also, you could try to run the following from Terminal as this will provide you with DEBUG information during Clone command.

GIT_SSH_COMMAND="ssh -vvv" git clone ssh://git@localhost:7999/proj/repository.git

Kind regards,
Rafael P. Sperafico

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

199 views 3 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you