RepositoryDeletedEvent action initiated during repo import

Whenever I'm trying to import a repo into a project through bitbucket UI, it shows progress bar and then fails with error. When i check the audit log of the project, there are two entries, one for repo creation (action mentioned as RepositoryCreatedEvent) and another for repo deletion (action mentioned as RepositoryDeletedEvent).

The Repo isnt created within the project. Has anyone else seen this error ? Is there a fix to do this through UI. 

(I can move the repo through admin UI options and clone and import repo through command line, but this option through UI isnt working. Is this a known bug ?)

1 answer

0 vote

Hi team,

 

The fact that the repository is deleted and therefore a RepositoryDeletedEvent message is added to the audit log is a symptom that the import failed. 

 

To understand the cause, you would need to check the error and warning messages in the atlassian-bitbucket.log file.

 

What is reported there?

 

Cheers,

Caterina

Error in logs reflect : fatal: Unable to find remote helper for 'https'

As per forums, the solution to the fix isnt clear as many have asked for re-installation of the git package. Could you specify which package is needed to resolve this ? 

 

To verify the git package, I tried cloning the package on my desktop and it worked fine.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

22,795 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you