Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

NET_ERR in bitbucket

I'm having issues with Bitbucket.  When I copy the URL for the webhook into a browser, it works but does not work in Bitbucket.  The issue started happening last week.  Any ideas on why this may be the case?  Did their IP addresses change?

3 answers

If you have a firewall, you might check the ip access list.

Looks like they might have updated their ip addresses again.

Don't understand why they can't just keep those ip's consistent.

Maybe it's time to set up my git server...

https://ip-ranges.atlassian.com/

Don't tell me that I have to enter all 30 IP adresses to my router ip access list ? Or do I ?

I try to access a static IP Address on my Mac mini setup.

I am running Jenkins (more precisely the Jenkins Generic Webhook Trigger Plugin)

I would like to use a Bitbucket Webhook pointing to this Mac Mini's Jenkins server.

Everything works if I tunnel the Firewall.

The question is, how can I allow-list the Bitbucket IP Adresses (and which ones) so that the Bitbucket Webhook works ?

 

@Stephan Korner did adding the IPs solve the problem?

Comment from other forum with the same issue:

I tried to add all the cidr’s from https://ip-ranges.atlassian.com/ (count = 85) to the outbound security group in our AWS server but got error like “Number of IPs is more than acceptable limit“. Can you please correct me if I am doing anything wrong?

https://jira.atlassian.com/browse/BCLOUD-17668?focusedCommentId=2260219&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-2260219

i changed from https to http, then it was fine

Hi Jerry,

My server (that will receive and process the webhook post) speaks only HTTPS.

So possibly this is not an option for me. Correct? 

don't know.. 

@abhishek_madhu Any resolution ? I have the same issue now. Http works and HTTPS says NET_ERR

0 votes

Hello Kenneth,

We need further information to assist with finding out where your issue is within bitbucket. Can you please provide the following information?

Are you using Bitbucket cloud or server?

Where are you submitting the URL within Bitbucket and what does the error look like (please include a screenshot)?

There was a change which added new IP addresses for Bitbucket cloud, but this was back in July 2018 and was to be completed by August 2018. You can find more on that in the blog post; New IP addresses for Bitbucket Cloud

Once we have additional information we can start working on a resolution for you.

Regards,
Stephen Sifers

Hi Stephen,

 

We are facing the same issue with BitBucket.

We are using Jenkins with SSL verification and configured webhook for the repo as below:

https://jenkins-*****/bitbucket-hook/

I committed the code, but the build wasn't triggered.

When tried with another jenkins instance using http, it worked immediately.

Changing from https to http also did not help me.

With https, we are getting NET_ERR, and if i change it to http,we are getting a HTTP 503 error.

No luck with whatsoever.

Can you please help me out here.

We are using BitBucket Cloud.

 

Thanks,

Swetha

could be your companies firewall needs to have the port opened

Hi Jerry,

I have my Jenkins provisioned on AWS.

And I have opened both http and https ports in the security group attached to the EC2 instance.

Please let me know if need to check anything else.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

117 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you