Import a large git repository into stash

Hi, All:

I have just setup a stash server and would like to import a large git repository (~700MB) into stash. I'm getting 'error: RPC failed; result=22, HTTP code = 413'. What server configurations should I change in order to resolve this issue.

Thanks,

Xun.

1 answer

0 votes
Daniel Wester Community Champion May 03, 2014
You'll need to take a look at the server logs. Do you have apache or nginx in front of the server and are you doing the git push over the http protocol? If so the proxying web server might have the error

I have lighttpd as my front end. I've tried to set server.max-request-size (default is 2GB and I've tried 20GB) and set maxPostSize="0" in server.xml for tomcat. It seems to have no effect. Perhaps, I've tried too quickly late at night and might made a mistake. I should give it another go tonight.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

451 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you