Bitbucket server setup: not progressing after entering licence key

Hi

New installation Bitbucket server on Ubuntu 14.04.4 and just bought a Bitbucket Starter license

Every step went fine until entering the License key

1) First nothing happens when select "I have a Bitbucket license key"

though if I hit Enter, then the textarea appears where the licenkey can be pasted, ofc claiming "Please enter a non-blank value"

2) ...ok but now I could at least paste the licence key and press Next. But  all I get back is the same page telling me "Please enter a non-blank value"

Hitting F12 gives me following if this can have anything to do with it:

Loading failed for the <script> with source “http://mlgeoo00mvxprt003:7990/s/819f68eb4220335cc34b92f05c15390c-CDN/-1519583252/92eb094/1/bd1dd30963b6f569f6bd15e4b213ef64/_/download/contextbatch/js/_super/batch.js?locale=en-US”.

(Tried Firefox, Chrome and IE)

 

Is it possible to enter the license key in any other way to get pass this setup step ?

FYI: The Ubuntu server has no direct access to internet  

 

Any ideas what to check for ?

 

//Erik

 

1 answer

1 accepted

1 vote

Hey Erik,

I attempted to reproduce your issue with the latest version of Bitbucket and your starter license, but I have been unable to do so. I too tested this on a freshly installed Ubuntu 14.04 instance.

When I paste the license key in the license key field and select next, I am taken to the next step in the wizard. I can only get the "Please enter a non-blank value" error when the license key field is left blank. 

There immediately seems to be an environmental issue that is interacting with your instance. A common theme is that this happens in different browsers for you.

Some Clarifying Questions

Do you have anything locally or within your environment that would prevent javascript execution?

Did you pre-configure any proxy information for Bitbucket Server BEFORE starting the application for the first time? (Doesn't appear so from your javascript snippet.)

Does this happen on another users machine if they attempt to input the license key?

Alternative License Entry

The only other way to enter a license key outside of the UI is via unattended installs. This allows you to create a configuration file with your instance information including your license key.

-Mark

Thanks for your efforts. 

We are on a VPN accessing this server. Just tried using Remote Desktop to a machine on same network as Ubuntu server and then it worked perfect.

Really strange, we have not had any issues running javascripts on any servers in this network from our VPN before, will talk to network guys

Thanks again

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,872 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you