After upgrade to stash 3.2 subgit mirroring stopped working

I just raised this issue in tmatesoft's support portal:

http://issues.tmatesoft.com/issue/SVNKIT-545

 

But would also like to try my luck here as its urgent.

 

We just did an upgrade from stash 2.10 to 3.2. The upgrade went smoothly, after that we are forced to upgrade the subgit plugin to the latest, which we did.

Then we cannot push to git at all, but the git pull or svn commit all worked (svn checkin will commit to git repo and pulling git repo will give you the latest version).

Here is the error on the client side:

seek_master git:(master): git push origin master

remote: Synchronizing SVN and Git...

remote:   translating SVN revisions to Git commits...

remote:   translating Git commits to SVN revisions...

remote: ... done.

remote: 

remote: SubGit ERROR REPORT (SubGit version 2.0.3-EAP ('Patrick') build #2788):

remote: 

remote: You've received this message because SubGit (http://subgit.com) is installed in your repository

remote: and an error that needs to be dealt with has occurred in SubGit translation engine.

remote: 

remote: TEMPORARY ERROR:

remote:         Failed to push some refs to Subversion repository.

remote: svn: E175002: COPY of /svn/seek/!svn/bc/20762/trunk: 501 Method Not Implemented (http://ak1vsvrpap03.finzoffice:81)

remote: 

remote: 

remote: CURRENT STATE:

remote:         Both Git and Subversion repository are open for pushes or commits.

remote:         Your commit was not committed, but you may retry it.

remote: 

remote: TO RECOVER:

remote:           A) Address the problem if possible and then retry commit

remote:         OR

remote:           B) Run on the server

remote:              $ subgit uninstall D:\stash_home\shared\data\repositories\131

remote: 

remote:         IMPORTANT: As soon as SubGit is uninstalled, both Git and Subversion repositories

remote:                    will become open, but no synchronization will take place.

remote: 

remote: TO REPORT:

remote:         Report an issue at http://issues.tmatesoft.com/

remote:         You may find logs on the server at 'D:\stash_home\shared\data\repositories\131\subgit\logs'

remote: 

remote: THANK YOU!

To ssh://git@ak1vsvrpap03.finzoffice:7999/seek_svn/seek_svn.git

 ! [remote rejected] master -> master (pre-receive hook declined)

error: failed to push some refs to 'ssh://git@ak1vsvrpap03.finzoffice:7999/seek_svn/seek_svn.git'

 

 

On the server side, in the subgit logs:

 

 

[2014-09-10 10:08:15.847][pre-receive-hook][333] Failed to push some refs to Subversion repository.
svn: E175002: COPY of /svn/seek/!svn/bc/20762/trunk: 501 Method Not Implemented (http://ak1vsvrpap03.finzoffice:81)

org.tmatesoft.translator.util.e: Failed to push some refs to Subversion repository.
svn: E175002: COPY of /svn/seek/!svn/bc/20762/trunk: 501 Method Not Implemented (http://ak1vsvrpap03.finzoffice:81)

  

 
 at org.tmatesoft.translator.util.e.b(SourceFile:24)
 at org.tmatesoft.translator.c.g.a(SourceFile:249)
 at org.tmatesoft.translator.d.c.doExecute(SourceFile:123)
 at org.tmatesoft.translator.d.h.doExecute(SourceFile:54)
 at org.tmatesoft.translator.d.c.execute(SourceFile:62)
 at org.tmatesoft.subgit.stash.web.hooks.SgPreReceiveRepositoryHook.doPreReceive(SourceFile:106)
 at org.tmatesoft.subgit.stash.web.hooks.SgPreReceiveRepositoryHook.onReceive(SourceFile:68)
 at com.atlassian.stash.internal.hook.DefaultBuiltInHookHandlerFactory$1.handle(DefaultBuiltInHookHandlerFactory.java:43)
 at com.atlassian.stash.internal.hook.DefaultHookService.doHandleRequest(DefaultHookService.java:353)
 at com.atlassian.stash.internal.hook.DefaultHookService.handleRequest(DefaultHookService.java:339)
 at com.atlassian.stash.internal.hook.DefaultHookService.handleRawRequest(DefaultHookService.java:250)
 at com.atlassian.stash.internal.hook.DefaultHookService$2$1.run(DefaultHookService.java:210)
 at com.atlassian.stash.internal.concurrent.StateTransferringExecutor$StateTransferringRunnable.run(StateTransferringExecutor.java:69)
 at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
 at java.util.concurrent.FutureTask.run(Unknown Source)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
 at java.lang.Thread.run(Unknown Source)

 

 

Any help will be appreciated!

2 answers

1 accepted

This issue is a bug that existed in 2.0.12 of the svn mirroring addon, after we reported it now they fixed it in 2.0.12.1. CHeers

 

0 vote

Hi Jason,

After the Stash 3.0 release, some plugins became incompatible due to the removal of some REST API's (please refer to the Plugin incompatibility with Stash 3.0. I noticed on the vendor's plugin in Marketplace that the 2.0.10 is their oldest release compatible with Stash.

That being said, could you please review your plugin version? If it is 2.0.3 as I could see from your logs above, that should help you fix the issue.

Best regards,
Thiago Bomfim
Atlassian Support

Thanks for the prompt reply, Thiago, I just checked the addon version, it definitely says 2.0.12. You are quite right about the log on the client side, looks like the old version is still in play! Whats the best way for me to be certain we are using the 2.0.10 version? Can I physically remove some file? Thanks Jason

Just realized the version 2.0.3 is the sub git server version, which is the latest and 2.0.12 is the stash add on svn mirroring version. They do not need to match I guess. So that would not be the cause...

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,011 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you