Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

- pipe: microsoft/azure-aks-deploy:1.0.2

Getting the error "No such file or directory exist " on using the 

- pipe: microsoft/azure-aks-deploy:1.0.2

 

 

 

3 answers

1 vote

@Reethu  are you still having the issue? 

Unfortunately, I should announce that microsoft does not support this pipe anymore. Instead atlassian supports this instead. Please, use readme from here for more examples https://bitbucket.org/atlassian/azure-aks-deploy/src/master/ .

If you're still having the issue, could you please share more logs? I've just executed both variants (BIT with space, pipe: atlassian/azure-aks-deploy:1.0.2) and it worked.

Please, report to us, if you have questions or issues with this pipe. For now I cannot reproduce your case.

Regards, Galyna

0 votes

Hi @Reethu ,

Thank you for your question!

It would be nice if you could share with us more details about your case: logs, pipelines configuration, etc.

 

Cheers,
Oleksandr Kyrdan

Thanks Oleksandr  for prompt response.

while configuring the bitbucket pipeline to deploy my image from azure container registry to azure kubernetes, i am using two steps:

- Build -(ran successfully)
 - step: &Deploy
image:
name: atlassian/default-image:2
name: Deploy Image
trigger: manual
script: 
- pipe:microsoft/azure-aks-deploy:1.0.2
variables:
AZURE_APP_ID: *****
AZURE_PASSWORD: ****
AZURE_TENANT_ID: ******
AZURE_AKS_NAME: ******
AZURE_RESOURCE_GROUP: ******
KUBECTL_COMMAND: 'apply'
KUBECTL_ARGUMENTS: '-f  ******.yaml'
DEBUG: 'true' # Optional


while triggering the deploy from pipeline , am getting error like below on executing script in deploy step.

+ pipe:microsoft/azure-aks-deploy:1.0.2
bash: pipe:microsoft/azure-aks-deploy:1.0.2: No such file or directory.


Am getting same error on trying with pipes 
pipe:atlassian/azure-aks-deploy:1.0.2
pipe:microsoft/azure-aks-deploy:1.0.2

0 votes

@Reethu How did you create your pipeline yml? Have you checked this doc?

I rechecked on this doc  , and copied the pipe  'script: - pipe: atlassian/azure-aks-deploy:1.0.2 .

Thanks !

Thanks for the response

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

3,648 views 63 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you