It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

aws-cloudformation-deploy doesn't work when running as custom or from tag

Whenn running the aws-cloudformation-deploy pipeline (0.6.1) from a custom call or tags it fails with the error

Invalid type for parameter Tags[1].Value, value: None, type: <class 'NoneType'>, valid types: <class 'str'>

That seems to be due to a default tag using BITBUCKET_BRANCH which doesn't exist in that case

1 answer

0 votes

@Ronald Fischer you're right, there is a bug in the pipe, which doesn't handle missing BITBUCKET_BRANCH variable. We'll fix the bug asap and let you know.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

411 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you