Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bit bucket scp pipe is not using SSH_KEY

Using the SSH_KEY of the pipe https://bitbucket.org/atlassian/scp-deploy/src/master/

is not working.

Every time I get:

scp -rp -i /opt/atlassian/pipelines/agent/ssh/id_rsa_tmp -P 22 Warning: Identity file /opt/atlassian/pipelines/agent/ssh/id_rsa_tmp not accessible: No such file or directory.Host key verification failed.lost connection

 

This is my code: 

- pipe: atlassian/scp-deploy:0.3.4
variables:
USER: $SSH_USER
SSH_KEY: $SSH_DEPLOY_KEY
SERVER: $SSH_SERVER
REMOTE_PATH: '~/back-develop/docker-compose.yml'
LOCAL_PATH: 'docker-compose.yml'
DEBUG: 'true'
EXTRA_ARGS: '-P $SSH_PORT'

The `SSH_DEPLOY_KEY` is normally correct as it is working for the pipe `atlassian/ssh-run`. So it's a base64 encoding of the key that I added to my repository variables.

1 answer

Hi @robin , could you try remove the SSH_KEY parameter and configure SSH keys from the repository settings as described here https://confluence.atlassian.com/bitbucket/use-ssh-keys-in-bitbucket-pipelines-847452940.html ?

P.S. Sorry for such a late reaction, the question fell of our radars for some reason.

I have the same issue: The `SSH_DEPLOY_KEY` is normally correct as it is working for the pipe `atlassian/ssh-run`. So it's a base64 encoding of the key that I added to my repository variables. But in atlassian/scp-deploy:0.3.12 does't work.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

632 views 15 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you