Provisioning not working with Okta

jake.platt December 18, 2019

I turned on Access for a trial to make sure it will work for us and the company would be willing to pay for it. I have configured the domain, captured our accounts, setup okta SAML and turned on provisioning. I pushed a test group and it pushed a single user to Atlassian out of the ~130 users who have an account on our Atlassian account. Unfortunately it will not sync the rest of the users from okta into atlassian. What am I missing? 

3 answers

1 accepted

2 votes
Answer accepted
jake.platt December 23, 2019

Answer came through support ticket. Users that are granted access to Atlassian access through okta before provisioning is setup will not automatically line up. Their access needs to be removed through okta and re-added. Either that or setup provisioning before assigning any users to atlassian from okta. 

0 votes
Prakash Kumar March 23, 2020

We've recently released Jira User Sync/Provisioning plugin which provisioned all Users and groups from Cloud Identity provider(Okta) to Jira.

 

You can take a look: https://marketplace.atlassian.com/apps/1222000/user-group-sync-for-jira?hosting=server&tab=overview

 

Here is the setup steps: https://plugins.miniorange.com/user-and-group-sync-user-provisioning-okta 

 

Thanks,

Prakash

andy.pawl June 23, 2021

Will this plugin allow for Okta to update existing groups in Atlassian such as the jira-user Group or do groups need to be created in Okta and then pushed to Atlassian?

Devin Ponda August 3, 2022

FYI: above mentioned plugin is Server only

0 votes
jake.platt December 19, 2019

so first thing that got me started on a small scale (still not working completely.) is to have a group in okta that has access to confluence. It didn't work to just do a bunch of users to sync with our access list. So far it is less than 50 percent of my users in the group in question. Not sure where to go from here. 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events