Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,554
Community Members
 
Community Events
168
Community Groups

User agent string value not showing EDGE browser info

I have tried getting the user agent string for the issue created and when anychanges were made to them but my scripted field is capturing the value for the Firefox and Chrome browser only .

when the changes are made to the issue in the EDGE browser the value for the user sgent string is coming out as Chrome .

 

Is it a glitch Or something ??

 

Can somebody help

1 answer

1 accepted

1 vote
Answer accepted

No it is not a glitch. In simple words MS Edge is infact just a skin/Theme for Chrome. Normally the user-agent for edge says Edg or Edge but older websites cannot detect the new edge browser so they detect chrome due to compatibility.

which product version are you using? an upgrade might help here.

I am currently using V 6.18 for the script runner and the edge browser is 88.0.705

 

if you see in the attach it shows that edge value is detected but browser comes upto be as chrome. Capture2.PNG

i thought that edge and chrome are from two different companies microsoft and google never  knew that it was the theme or the skin for Chrome . Let me check on that  

Edge and Chrome are indeed from MS and Google respectively.  MS dumped their browser technology and move to Chrome when they started building Edge.  Officially it was it makes no commercial sense to build your own tech, but from what I've heard and read, it was more to do with the MS technology being broadly rubbish and needing too much work to fix it.

Thank you @Danyal Iqbal @Nic Brough _Adaptavist_  for your response . i have made my research about it and i am satisfied

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events