Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Scriptrunner post function clones an issue, and links is not cloning attachments

Using Scriptrunner post function on a workflow transition.

I'm using the post function : Clones an issue, and links, and expect the attachments clone from the original issue to the new issue. But upon typing attachments into the Fields to copy box, I get a No Matches found on Attachments.

I'm cloning from one project to a different project. Target issue type is left to the default of the original project.

image.pngimage.png

1 answer

I would solve this by either:

1) Writing a separate post function which would copy attachments from the original issue 

or

2) Write a custom post function which would clone the issue with all required fields and attachments

Thanks Ivan! Not sure why, possibly a jira version upgrade, but I am able to add attachments now on the clone. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

142 views 1 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you