I have an application server (Win2012 R2, 64bit) running Bitbucket 5.10.1, and was on an older version of Java. Bitbucket, confluence, and Jira was working fine until I installed the updated version of Java (8.0_191). After restarting the server, I noticed bitbucket and confluence services would not start. When I attempt to manually restart them, they will not start and windows will give a "code 1" error. In the system events log, I find that a "service terminated: Incorrect function" error comes up.
I set the environmental variables for JAVA_HOME to the new install path of java, but this did not resolve the issue. Jira appears to be working fine. What else could I try?