Hi Everyone
Have just started with a new company who use Jira. Personally I have never used it or seen it before so please excuse my ignorance on this platform.
There are two VMs running Windows 2012 R2. One VM has Jira Software v 7.0 installed with the other VM running the SQL 2012 hosting several databases including the Jira instance.
The company have tasked me with not only upgrading to the latest version but also to cluster the platform. Being an Agile based company they rely heavily on this platform with a recent outage highlighting just how heavily dependent they are on this platform. Hence the reason for implementing HA.
So a few initial questions:
Can Jira v7.0 be upgraded direct to v 7.13 or should the upgrade be more staged?
If possible, I would prefer to install a new Jira v7.13 cluster with a new SQL instance on the existing SQL server and restore the present Jira database into the new SQL instance. Is this a possible approach?
Initial investigation into configuring a Jira cluster highlights the need for a front end load balancer, with the respective schematics indicating this needs to be a layer 1 (physical) load balancer. Is this necessary? I would have expected a clustered VIP to provide the load balancing?
Any links to respective docs would be appreciated and thanks in advance for your help.
Vyvyan
Hi Again Guys.
As per your advice have conducted considerable testing of the upgrade process of JIra Core 7.0 to 7.13, within an isolated test environment. A am now looking for your assistance again with the upgraded instance of Jira failing to start a whole bunch of plugins.
Have 2 VMs running Server 2012 R2 with 24Gb RAM, 8 x 8 core CPUs and 100GB system partition. One VM ruinning Jira and the other running SQL 2012.
After a few "gotchas" the following is the process taken to get to my present point.
1) Used SQL native tools to peform database backup
2) Stop Atlassian Jira service. Problems were experienced during initial attempt with failing to upgrade files that were locked by process.
3) Applied Full Control NTFS permissions to account running Jira upgrade to everything under c:\program files\Altlassian\*.*. Although the account is a Domain Admin account was unable to save the dbconfig.xml during the config.bat process.
Can detail the plugins not strating if you wish but there is so many of them and I can Cut\Paste the screen prompt.
HELP!!!