During upgrade from 6.14 to more recent version the Jira has been upgraded first to 7.0.0 as suggested by official guides. Old version and intermediary version (7.0.0) are both running on in-memory DB. The target version is using Oracle 11g.
Import from 6.14 to 7.0.0 went fine. However, during import of backup from 7.0.0 to target Jira version this error occurs:
com.atlassian.activeobjects.spi.ActiveObjectsImportExportException: There was an error during import/export with plugin JIRA DVCS Connector Plugin(com.atlassian.jira.plugins.jira-bitbucket-connector-plugin) #4.0.14 (table AO_E8B6CC_REPOSITORY_MAPPING_COPY_331_12):Error executing update for SQL statement 'ALTER TABLE "AO_E8B6CC_REPOSITORY_MAPPING_COPY_331_12" DISABLE ALL TRIGGERS'
at com.atlassian.activeobjects.backup.ImportExportErrorServiceImpl.newImportExportSqlException(ImportExportErrorServiceImpl.java:26)
......
Caused by: java.sql.SQLSyntaxErrorException: ORA-00972: identifier is too long
The identifier AO_E8B6CC_REPOSITORY_MAPPING_COPY_331_12 is 40 characters long which is above Oracle 11g's limit of 30 characters for identifiers.
Moreover, in entities.xml DVCS plugin explicitly references "AO_E8B6CC_REPOSITORY_MAPPING" table. Where that extra comes from?