Kindly help me with this screen shot my license was expired for jira then i renewed the license. Now i want to renew but this is giving an error for logs as this. Help asap. Regards
Could you give us the plain text of the first few lines of that error? It's just small enough that it's not 100% readable.
I can make out you've got an SQL error, which suggests a broken database link, but can't make out the rest
com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:DELETE FROM PUBLIC.rundetails WHERE START_TIME < ? (General error: "java.lang.IllegalStateException: File corrupted in chunk 253971, expected page length =< 48, got 828518754 [1.4.185/6]"; SQL statement: DELETE FROM PUBLIC.rundetails WHERE START_TIME < ? [50000-185]) at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.removeByCondition(DefaultOfBizDelegator.java:144) at com.atlassian.jira.ofbiz.WrappingOfBizDelegator.removeByCondition(WrappingOfBizDelegator.java:136) at com.atlassian.jira.entity.Delete$DeleteWhereContext.execute(Delete.java:154) at com.atlassian.jira.entity.EntityEngineImpl.delete(EntityEngineImpl.java:55) at com.atlassian.jira.entity.Delete$DeleteWhereContext.execute(Delete.java:136) at com.atlassian.jira.scheduler.OfBizRunDetailsDao.purgeHistory(OfBizRunDetailsDao.java:130) at com.atlassian.jira.scheduler.OfBizRunDetailsDao.start(OfBizRunDetailsDao.java:70) at com.atlassian.jira.scheduler.JiraCaesiumSchedulerService.startRunDetailsDao(JiraCaesiumSchedulerService.java:71) at com.atlassian.jira.scheduler.JiraCaesiumSchedulerService.startImpl(JiraCaesiumSchedulerService.java:35) at com.atlassian.scheduler.core.AbstractSchedulerService.start(AbstractSchedulerService.java:180) at com.atlassian.jira.scheduler.JiraSchedulerLauncher.proceedIfAllClear(JiraSchedulerLauncher.java:37) at com.atlassian.jira.scheduler.JiraSchedulerLauncher.start(JiraSchedulerLauncher.java:23) at com.atlassian.jira.startup.ActiveServicesLauncher.start(ActiveServicesLauncher.java:56) at com.atlassian.jira.startup.DefaultJiraLauncher.postDBActivated(DefaultJiraLauncher.java:181) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:155) at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:304) at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:199) at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:146) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:105) at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31) at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:103) at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:157) at java.lang.Thread.run(Thread.java:745) Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:DELETE FROM PUBLIC.rundetails WHERE START_TIME < ? (General error: "java.lang.IllegalStateException: File corrupted in chunk 253971, expected page length =< 48, got 828518754 [1.4.185/6]"; SQL statement: DELETE FROM PUBLIC.rundetails WHERE START_TIME < ? [50000-185]) at org.ofbiz.core.entity.jdbc.SQLProcessor.executeUpdate(SQLProcessor.java:570) at org.ofbiz.core.entity.GenericDAO.deleteByCondition(GenericDAO.java:1238) at org.ofbiz.core.entity.GenericHelperDAO.removeByCondition(GenericHelperDAO.java:244) at org.ofbiz.core.entity.GenericDelegator.removeByCondition(GenericDelegator.java:1370) at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.removeByCondition(DefaultOfBizDelegator.java:142) ... 22 more Caused by: org.h2.jdbc.JdbcSQLException: General error: "java.lang.IllegalStateException: File corrupted in chunk 253971, expected page length =< 48, got 828518754 [1.4.185/6]"; SQL statement: DELETE FROM PUBLIC.rundetails WHERE START_TIME < ? [50000-185] at org.h2.message.DbException.getJdbcSQLException(DbException.java:345) at org.h2.message.DbException.get(DbException.java:168) at org.h2.message.DbException.convert(DbException.java:295) at org.h2.command.Command.executeUpdate(Command.java:262) at org.h2.jdbc.JdbcPreparedStatement.executeUpdateInternal(JdbcPreparedStatement.java:157) at org.h2.jdbc.JdbcPreparedStatement.executeUpdate(JdbcPreparedStatement.java:143) at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:98) at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:98) at org.ofbiz.core.entity.jdbc.SQLProcessor.executeUpdate(SQLProcessor.java:562) ... 26 more Caused by: java.lang.IllegalStateException: File corrupted in chunk 253971, expected page length =< 48, got 828518754 [1.4.185/6] at org.h2.mvstore.DataUtils.newIllegalStateException(DataUtils.java:773) at org.h2.mvstore.Page.read(Page.java:640) at org.h2.mvstore.Page.read(Page.java:194) at org.h2.mvstore.MVStore.readPage(MVStore.java:1830) at org.h2.mvstore.MVMap.readPage(MVMap.java:736) at org.h2.mvstore.Page.getChildPage(Page.java:216) at org.h2.mvstore.Cursor.fetchNext(Cursor.java:150) at org.h2.mvstore.Cursor.next(Cursor.java:50) at org.h2.mvstore.db.TransactionStore$TransactionMap$1.fetchNext(TransactionStore.java:1396) at org.h2.mvstore.db.TransactionStore$TransactionMap$1.next(TransactionStore.java:1435) at org.h2.mvstore.db.MVSecondaryIndex$MVStoreCursor.next(MVSecondaryIndex.java:508) at org.h2.index.IndexCursor.next(IndexCursor.java:277) at org.h2.table.TableFilter.next(TableFilter.java:360) at org.h2.command.dml.Delete.update(Delete.java:70) at org.h2.command.CommandContainer.update(CommandContainer.java:78) at org.h2.command.Command.executeUpdate(Command.java:254) ... 31 more
above is the complete log of jira error. i have paid the license fee and have got the keys on online account. BUT my system where jira is installed is giving errors i cant add the keys to it.
Ok, that's readable.
You have a broken database. There is a line in your log that says "Caused by: java.lang.IllegalStateException: File corrupted in chunk 253971, "
This could be fatal - the h2 database is not suitable for production work, only dev and test, as it can fail without warning (especially with larger data sets), and when it does, it often fails catastrophically.
You might try to rescue it, but with a failed h2 database, it's often not really going to work and your best option is to start again. Ideally using a supported database instead of h2.
It looks like you're new here. Sign in or register to get started.