Hi!, I created a simple pipeline to run "docker-compose up" and then "docker-compose down", everything is correct, the images get build correctly, but it throws an error when is going to create the container. the error is:
ERROR: for build_db_1 Cannot create container for service db: authorization denied by plugin pipelines: -v only supports $BITBUCKET_CLONE_DIR and its subdirectories
I have no clue of what this means. The pipeline is the following:
image: docker:stable
options:
docker: true
pipelines:
default:
- step:
script:
- chmod 777 ci/dependencies.sh
- ci/dependencies.sh
- docker-compose up -d --build
- docker-compose down
dependencies.sh
#!/usr/bin/env sh
set -eu
# Add python pip and bash
apk add --no-cache py-pip bash
# Install docker-compose via pip
pip install --no-cache-dir docker-compose
docker-compose -v
What is this error telling me? Thank you!