I am installing Confluence on Debian 9 and it fails to start the synchrony proxy with an out of memory error - unable to create new native thread.
My setup:
- - virtual server env with debian 9
- - mariadb 10.1
- - confluence 6.11
- - apache2 as ssl proxy
- - mysql driver 5.1.47
Steps to reproduce issue:
- Get fresh virtual host install (debian 9).
- Install mariadb and apache2
- Start confluence installation from command line, without starting confluence
- Copy mysql driver to WEB-INF/lib
- Start confluence
- Choose own database and configure accordingly
- Setup example site
- Conclude setup
Expected result:
Confluence starts and shows login page
Actual result:
Confluence shows following error page -
Description: Unable to start up Confluence. Fatal error during startup sequence: confluence.lifecycle.core:dblowercheck (Check to ensure the database correctly supports lower() for non-ASCII characters)
Level: fatal
Exception: unable to create new native thread
Initial investigation into log files show that synchrony proxy fails to start because it is unable to create a new native thread (out of memory error).
I have run this config successfully on debian 8 and run into this problem after upgrading to debian 9.
Please advise.