Hello ,
I have been trying to run BitBucket on our server for long time but im getting stuck at this point. Kindly assist me to resolve the issue
HI @admin
Welcome to the community!
Could you please look at the <Bitbucket_Home>/log/atlassian-bitbucket.log file for details about the error.
Hello
Please find the log file.
2018-07-19 13:39:48,580 INFO [main] o.s.boot.SpringApplication. ____ _ __ _ _/\\ / ___'_ __ _ _(_)_ __ __ _ \ \ \ \( ( )\___ | '_ | '_| | '_ \/ _` | \ \ \ \\\/ ___)| |_)| | | | | || (_| | ) ) ) )' |____| .__|_| |_|_| |_\__, | / / / /=========|_|==============|___/=/_/_/_/:: Spring Boot :: (v1.5.12.RELEASE)
2018-07-19 13:39:48,828 INFO [main] c.a.b.i.b.BitbucketServerApplication Starting BitbucketServerApplication on jprdevops1 with PID 21038 (/opt/atlassian/bitbucket/5.12.0/app/WEB-INF/classes started by atlbitbucket in /opt/atlassian/bitbucket/5.12.0/bin)2018-07-19 13:39:48,828 INFO [main] c.a.b.i.b.BitbucketServerApplication No active profile set, falling back to default profiles: default2018-07-19 13:39:50,671 INFO [main] c.a.b.i.boot.log.BuildInfoLogger Starting Bitbucket 5.12.0 (02c9a7a built on Mon Jul 09 09:49:52 IST 2018)2018-07-19 13:39:50,671 INFO [main] c.a.b.i.boot.log.BuildInfoLogger JVM: Oracle Corporation Java HotSpot(TM) 64-Bit Server VM 1.8.0_171-b112018-07-19 13:39:52,613 ERROR [main] o.a.catalina.core.StandardService Failed to start connector [Connector[HTTP/1.1-7990]]org.apache.catalina.LifecycleException: Failed to start component [Connector[HTTP/1.1-7990]]at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:167)at org.springframework.boot.context.embedded.tomcat.TomcatEmbeddedServletContainer.addPreviouslyRemovedConnectors(TomcatEmbeddedServletContainer.java:265)at org.springframework.boot.context.embedded.tomcat.TomcatEmbeddedServletContainer.start(TomcatEmbeddedServletContainer.java:208)at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.startEmbeddedServletContainer(EmbeddedWebApplicationContext.java:297)at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.finishRefresh(EmbeddedWebApplicationContext.java:145)at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:546)at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:122)at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:693)at org.springframework.boot.SpringApplication.refreshContext(SpringApplication.java:360)at org.springframework.boot.SpringApplication.run(SpringApplication.java:303)at com.atlassian.bitbucket.internal.boot.BitbucketServerApplication.start(BitbucketServerApplication.java:246)at com.atlassian.bitbucket.internal.boot.BitbucketServerApplication.main(BitbucketServerApplication.java:82)at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:48)at org.springframework.boot.loader.Launcher.launch(Launcher.java:87)at com.atlassian.bitbucket.internal.launcher.BitbucketServerLauncher.start(BitbucketServerLauncher.java:151)at com.atlassian.bitbucket.internal.launcher.BitbucketServerLauncher.main(BitbucketServerLauncher.java:99)... 5 frames trimmedCaused by: org.apache.catalina.LifecycleException: Protocol handler start failedat org.apache.catalina.connector.Connector.startInternal(Connector.java:1020)... 16 common frames omittedCaused by: java.net.BindException: Address already in useat sun.nio.ch.Net.bind0(Native Method)at sun.nio.ch.Net.bind(Net.java:433)at sun.nio.ch.Net.bind(Net.java:425)"atlassian-bitbucket.log" 198L, 19744C
That tells you that there is something already running on port 7990.
You'll need to stop that process (it may be Bitbucket is already running though!), or reconfigure Bitbucket so that it uses some other port.
Try a netstat on the server to see what process has that port open already.
I tried using other ports but its picking up 7990 by default after installation.
It looks like you're new here. Sign in or register to get started.