Would someone be able to tell me if this is expected behavior?
I'm running Confluence 5.3. When I upload a new version of an attachment, using the Image Macro, either by navigating to the file location or dropping the file, I get the following error message:
Could not upload the file to Confluence. The server may be unavailable.
This does not occur when I originally upload the attachment (version 1). To upload a new version of the attachment, I have to either completely remove the attachment or go to Tools > Attachment and then "Lock to Edit" the attachment.
In previous versions of Confluence, I was able to overwrite existing versions via the in-text editing. Is this no longer the case or is this a bug?