Hello,
on our migrated Confluence System behind an Apache Reverseproxy we get the Error that the Editor won´t start or that the websocket configuration on the reversproxy is wrong. Then I modified the Virtual Host configuration but it had no effect. Couriosly I get the same Error when i´m accessing Confluence without reverse Proxy. My virtual host configuration looks like this:
<VirtualHost *:443>
ServerName confluence.company.com
ServerAlias confluence.company.com
ProxyRequests Off
ProxyPreserveHost On
<Proxy *>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://127.0.0.1:8090%{REQUEST_URI} [P]
</Proxy>
ProxyPass / http://127.0.0.1:8090/
ProxyPassReverse / http://127.0.0.1:8090/
ProxyPass "/ws/" "ws://127.0.0.1:8080/"
ProxyPass "/wss/" "wss://127.0.0.1:8080/"
SSLEngine On
SSLCertificateFile /etc/pki/CA/certs/conflu.pem
SSLCertificateKeyFile /etc/pki/CA/certs/conflukey.pem
</VirtualHost>
I hope someone out there has an Idea or a configuration i could try out...
Best Regards
Thomas