As of today our Google Apps account is reporting that emails coming from our JIRA Server instance are unable to be verified as coming from our domain. The setup is as follows (HOSTNAME:IP) ...
MTA.TLD: 1.1.1.1
JIRA.TLD: 2.2.2.2
1.1.1.1 is in our SPF record and email from other clients using 1.1.1.1 as SMTP get delivered with no issues. When sending through JIRA with 1.1.1.1 configured as SMTP the SPF fails with the following
Received: from MTA.TLD (MTA.TLD. [1.1.1.1])
by mx.google.com with ESMTPS id SOME_ID
for <user@domain.com>
(version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Wed, 20 Jun 2018 07:30:14 -0700 (PDT)
Received-SPF: fail (google.com: domain of jira@domain.com does not designate 2.2.2.2 as permitted sender) client-ip=2.2.2.2;
Authentication-Results: mx.google.com;
spf=fail (google.com: domain of jira@domain.com does not designate 2.2.2.2 as permitted sender) smtp.mailfrom=jira@domain.com
Received: from JIRA.TLD (JIRA.TLD [2.2.2.2]) by MTA.TLD (Postfix) with ESMTP id SOME_ID for <user@domain.com>; Wed, 20 Jun 2018 07:30:13 -0700 (MST)The only thing I could find about what might cause this is if the client is using it's own mail relay to send email to MTA.TLD, best I can tell from the SMTP logs when sending test emails this is not the case with JIRA but I'm not entirely sure. Does anyone know if this is the case or of something else that might be causing this validation error or for SPF validation to use the client-ip rather than the MTA ip?