Hi All
Context: JIRA 7.2.7 version.
I recently migrated our database from MySQL to PostGre SQL (unsing XML export import procedure).
After migration to PostGres i am observing this error in the logs everytime i create a new issue.
I created the PostGreSQL database as described in the JIRA documentation.
I have also tried performing reindexing several times (even with deleting the caches folders) but has not worked.
Please help me identify what may be the root cause to this.
Error log:
2018-06-06 06:42:35,186 http-nio-8090-exec-11 WARN john 402x180x1 19e1ew6 172.xx.xxx.xx,10.xxx.xxx.xx /secure/CreateIssueDetails.jspa [c.a.j.issue.index.DefaultIssueDocumentFactory] Error indexing issue TEST-674: Dropping 'customfield_12760'
com.atlassian.activeobjects.internal.ActiveObjectsSqlException: There was a SQL exception thrown by the Active Objects library:
Database:
- name:PostgreSQL
- version:9.2.23
- minor version:2
- major version:9
Driver:
- name:PostgreSQL Native Driver
- version:PostgreSQL 9.1 JDBC4 (build 903)
org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "AO_60DB71_LEXORANK_pkey"
Detail: Key ("ID")=(5854) already exists.