I have a new install of Confluence on Server 2016 that is unable to connect to the marketplace from within the confluence application. I am able to access the site and ping the site from the server hosting Confluence.
The application is setup with a connector to support SSL, the base url is also set to an https address. It still does not work when I revert back to non ssl.
We do not use a proxy.