We have installed Confluence in Azure using Azure Marketplace template.
Now we are trying to configure SSL using Azure Application Gateway. We understand that the auto generated Public IP can’t be used in the Frontend IP configuration as it's already attached to a NIC.
We created a new Public IP and used it as Frontend IP and configured the Listener at HTTPS.
Now when we try to access the Confluence site using Https://newIP - we are able to browse it successfully but it gives the warning to change the Base URL to this new URL. So we made this change.
Now it throws the warning:
Tomcat config is incorrect
The Tomcat server.xml has an incorrect configuration:
scheme should be 'https'
proxyName should be 'newIP'
proxyPort should be '443'
We made this change too in the server.xml file but the warning is still there.
Another problem with accessing Confluence site with https is that it does not allow to install any add-ons. It throws the error "An unexpected error occurred. Refer to the logs for more information."