I have been running Confluence on Windows 2012 server connecting to a stand alone SQL Server (on another Windows Server) for some time with no issues.
Recently decided to install Jira Software on the same Windows host as Confluence connecting to the same SQL Server that also hosts Confluence database. I have followed the Jira deployment on SQL server guide, created new empty database called jira, set the appropriate collation etc as in:
https://confluence.atlassian.com/adminjiraserver/connecting-jira-applications-to-sql-server-2012-938846858.html
The guide also says that the server-wide global SET NOCOUNT option must be se enabled. Since this is a server-wide setting it affects all connections and databases on that instance.
Setting NOCOUNT broke Confluence. It started throwing errors upon staring up, uploading documents, it would not create new page - it would just hang forever, it was not possible to go to configuration as it would throw an error upon elevating priviledges.
All errors were similar and todo with "null" values:
null id in com.atlassian.confluence.impl.journal.JournalEntry entry (don't flush the Session afterQuery an exception occurs
Upon turning back off the SQL wide setting NOCOUNT Confluence started working again but - as expected - Jira broke.
I have seen many posts suggesting it is possible to host both on the same SQL server. How?
Thanks