Just bought a Jira server starter license but I can't download the license as I get the error that the serverID is invalid. It is, however, directly copied from the server. The format seems different than the example? My serverID format: xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx which is clearly different from the example format.
I tried with the developer license and that is accepted with no issues. So what is wrong here??
Jira Server 7.7.0 + Postgresql 9.4 on Ubuntu 16.04
Note: I find it a bit weird that this issue needs to be resolved using a public forum!!