I am using virtually identical httpd configuration for JIRA and Confluence - the standard Atlassian recommended config.
JIRA has no problem with rebooting of the AWS EC2 machine.
Confluence, however, very often fails to start on reboot and the only way to get it work is to wait and after 10 minutes reboot again and then the instance starts properly.
During the 10 minute waiting, the httpd logs show
There is nothing odd in the Confluence logs during this time. However, the apache's returned code is 503 - Service unavailable whereas after then 10 minutes with successful reboot, the page keeps loading.
What could be the cause? Is it some delay needed for Apache httpd proxy to start working? How to fix?