Dear Team,
am getting the error:BitBucket Server: SpringMVC dispatcher [springMvc] could not be started on Ubuntu 16.04.1 LTS
i have already tried the steps which were mentioned.
Please help me out
Hi Shirish, to which steps are you referring to? Are you referring to SpringMVC dispatcher could not be started?
Keep in mind that the solution proposed in that article is referring to Stash (old version of Bitbucket Server) so if you're using Bitbucket Server, that will not help. If you have Bitbucket Server you should try:
$ cd /var/atlassian/application-data/bitbucket $ chown -R atlbitbucket:atlbitbucket *
Which is documented in this other article.
If you're still having trouble, let us know which version of Bitbucket Server are you using.
Best regards,
Ana
Dear @Ana Retamal
am still facing the same issue
Same error here...
chown -R atlbitbucket:atlbitbucket *
this did not help
turns out, that after a failed re-organisation of the SQL database was still locked. after removing the lock and restarting bitbucket, it worked again
this MSSQL command helped UPDATE DATABASECHANGELOGLOCK SET LOCKED=0, LOCKGRANTED=null, LOCKEDBY=null where ID=1;
Hi @Christopher Gray
Thank you for your response.
For BitBucket, am using Postgre SQL, I am not sure what would be the issue here.
having the same issue with postgresql. about to reinstall
Linux using systemd as the default init system.
So the DefaultTasksMax setting in systemd does not allow the creation of a sufficient number of threads.
This setting has a default of 512.
Increase the value of the DefaultTasksMax setting by changing the corresponding line in the /etc/systemd/system.conf to provide a higher number (for example 12288):
DefaultTasksMax=12288Restart Bitbucket Serveror the installation for the change to take effect!
It looks like you're new here. Sign in or register to get started.