We are using Bitbucket on centos6.9 . We have upgraded the Bitbucket from 4.14 to 5.5 and we followed the link below for configuring SSL on Bitbucket server.
https://confluence.atlassian.com/bitbucketserver/migrate-server-xml-customizations-to-bitbucket-properties-897811761.html
Bitbucket Server secured with SSL and additional connector to redirect HTTP requests
However, server keeps failing to start as logs are as below:
2017-11-29 12:16:27,921 ERROR [main] o.s.b.d.LoggingFailureAnalysisReporter
***************************
APPLICATION FAILED TO START
***************************
Description:
The Tomcat connector configured to listen on port 7990 failed to start. The port may already be in use or the connector may be misconfigured.
Action:
Verify the connector's configuration, identify and stop any process that's listening on port 7990, or configure this application to listen on another port.
2017-11-29 12:16:27,929 INFO [main] c.a.b.i.boot.log.BuildInfoLogger Bitbucket 5.5.1 has shut down