Hello,
on our Jira 7.4.4 the message
2017-11-21 09:48:27,156 http-nio-8080-exec-22 ERROR anonymous 588x218760x2 - 217.182.92.40,127.0.0.1 / [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet action threw exception
java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist!
at com.atlassian.plugin.webresource.assembler.DefaultWebResourceAssembler$2.requirePage(DefaultWebResourceAssembler.java:189)
at com.atlassian.jira.web.action.Dashboard.doExecute(Dashboard.java:187)
startet flooding the logs on 21st of Nov.
The full log for the this problem can be found here.
On the 22nd of November we attempted to install the current version of service desk via the applications page.
The installation wouldnt finish.
Sometime between Afternoon of the 22nd and Morning of the 23rd Jira stopped working, showing an error 500 page.
The service was restarted but 3 service desk plugins timed out:
3 plugins failed to load during JIRA startup.
'com.atlassian.servicedesk.frontend-webpack-plugin' - 'Service Desk Frontend Webpack Plugin' failed to load.
Application context initialization for 'com.atlassian.servicedesk.frontend-webpack-plugin' has timed out waiting for (&(objectClass=com.atlassian.servicedesk.internal.api.condition.SDOperationalConditionHelper)(objectClass=com.atlassian.servicedesk.internal.api.condition.SDOperationalConditionHelper))
It has the following missing service dependencies :
The full FAILED PLUGIN REPORT can be seen here
and the full log for the failed startup can be found here.
The failure is logged at this timestamp: 2017-11-23 08:50:49