I have linked a JIRA issue in a Confluence page. Usually this would show up in the JIRA issue under "Issue Links". But all I get is:

Page Failed to load
The page is linked and I can click the link and the Confluence page will open. But it doesn't show the page title in the JIRA issue.
This might be related to https://community.atlassian.com/t5/Jira-questions/WstxUnexpectedCharException-when-linking-to-JIRA-issue-in/qaq-p/677239
I have the same setup on a staging system where it works. I have not found any difference so far. Both systems access the same LDAP server fpr user management.
What I have found in the access logs (of the reverse proxy) is the following difference.
Working staging system:
"POST /rpc/xmlrpc?xoauth_requestor_id=u.ser HTTP/1.1" 200 625 "-" "Apache-HttpClient/4.4.1 (Java/1.8.0_151)"
Non-working live system:
"POST /rpc/xmlrpc?xoauth_requestor_id=u.ser HTTP/1.1" 403 928 "-" "Apache-HttpClient/4.4.1 (Java/1.8.0_151)"