Received the error message while transferring postgres database from bitbucket version 4.14 to upgraded bitbucket version 5.5.0
Postgres transition version is from 9.4 to 9.6
Any help/guidance is highly appreciated!
Detailed error message from logs below:
Caused by: liquibase.exception.DatabaseException: ERROR: there is no unique constraint matching given keys for referenced table "stash_user" [Failed SQL: CREATE TABLE public.bb_comment (id BIGINT NOT NULL, author_id INT NOT NULL, comment_text TEXT NOT NULL, created_timestamp TIMESTAMP WITHOUT TIME ZONE NOT NULL, entity_version INT NOT NULL, thread_id BIGINT, updated_timestamp TIMESTAMP WITHOUT TIME ZONE NOT NULL, CONSTRAINT pk_bb_comment PRIMARY KEY (id), CONSTRAINT fk_bb_comment_author FOREIGN KEY (author_id) REFERENCES public.stash_user(id), CONSTRAINT fk_bb_comment_thread FOREIGN KEY (thread_id) REFERENCES public.bb_comment_thread(id) ON DELETE CASCADE)]
Thanks!