It's been awhile since our small team has accessed JIRA. Today I went to the URL domain previously associated to our account.
https://iftsolutions.atlassian.net/
"Page unavailable" is displayed with a message from Atlassian, "The requested page failed to load. If the problem persists, please contact Cloud Support."
Billing records show this license is good until March 2018.
Please assist me with troubleshooting steps to resolve this issue.