Hi guys, i want to ask if how can i implement the password policy in ldap using crowd? i try adding a password policy in ldap but the crowd cannot read the password policy and there is no error showing.
Hello,
If you set a password complexity requirement in LDAP, members of the LDAP connected User Directory in Crowd will be constrained to the requirement you set.
Crowd doesn't read the policy, it just sends the password reset request to LDAP, and LDAP enforces the complexity policy. LDAP will not allow a password that does not adhere to the policy just because the request comes from Crowd.
In case you had not seen it, I wanted to share this article because it has a lot of interesting information about the way Crowd interacts with the different implementations of LDAP: Configuring an LDAP Directory Connector
Thanks,
Ann
I tried change user password restricted on the "Password Policy" in LDAP directory on Crowd.
From "ldappasswd" command on localhost(LDAP server), password policy is available and I can not use(change) invalid password. But from Crowd, I can use(change) invalid password.
According to OpenLDAP server log, Crowd sends not "PASSMOD" but "MOD" request to change user password field. OpenLDAP server and password policy module don't look password policy in case receiving "MOD" request.
from ldappasswd:
Jun 27 16:27:30 ip-10-40-65-124 slapd[2487]: conn=1067 op=1 EXT oid=1.3.6.1.4.1.4203.1.11.1Jun 27 16:27:30 ip-10-40-65-124 slapd[2487]: conn=1067 op=1 PASSMOD id="cn=test,ou=Users,dc=example,dc=com" old newJun 27 16:27:30 ip-10-40-65-124 slapd[2487]: conn=1067 op=1 RESULT oid= err=19 text=Password is not being changed from existing value
from Crowd:
Jun 27 16:30:51 ip-10-40-65-124 slapd[2487]: conn=1010 op=60 MOD dn="cn=test,ou=Users,dc=example,dc=com"Jun 27 16:30:51 ip-10-40-65-124 slapd[2487]: conn=1010 op=60 MOD attr=userPasswordJun 27 16:30:51 ip-10-40-65-124 slapd[2487]: conn=1010 op=60 RESULT tag=103 err=0 text=
I hope Crowd sends "PASSMOD" instead of "MOD" request to change user password field.(See also: https://github.com/LDAPAccountManager/lam/issues/26)
Jira sends MOD and not PASSMOD.
Maybe Atlassian wants to hash the password on the client side. This prevents LDAP password policies.
From the OpenLDAP documentation:
pwdCheckQualityThis attribute indicates if and how password syntax will be checkedwhile a password is being modified or added. If this attribute is notpresent, or its value is zero (0), no syntax checking will be done. Ifits value is one (1), the server will check the syntax, and if theserver is unable to check the syntax, whether due to a client-sidehashed password or some other reason, it will be accepted. If its valueis two (2), the server will check the syntax, and if the server isunable to check the syntax it will return an error refusing thepassword.
pwdCheckQuality
This attribute indicates if and how password syntax will be checkedwhile a password is being modified or added. If this attribute is notpresent, or its value is zero (0), no syntax checking will be done. Ifits value is one (1), the server will check the syntax, and if theserver is unable to check the syntax, whether due to a client-sidehashed password or some other reason, it will be accepted. If its valueis two (2), the server will check the syntax, and if the server isunable to check the syntax it will return an error refusing thepassword.
The LDAP password policy is enforced by the LDAP server. It is not an informational record for a client application like Crowd.
If the LDAP server should enforce the password policy, the LDAP server needs to know the password. This means Crowd must write the password in PLAINTEXT to the LDAP server. In order to prevent, that the password gets written unencrypted to the database, you have to set in the ppolicy overlay of OpenLDAP the following attribute:
olcPPolicyHashCleartext: TRUE
But be warned. At least Jira generates extremly ugly error messages, if the LDAP server rejects the password, because it does not fulfill the requirements. See here:
https://community.atlassian.com/t5/Jira-questions/Dialog-box-when-LDAP-password-policy-rejects-password/qaq-p/1315744
It looks like you're new here. Sign in or register to get started.