We've got a Python-based app server running on a Linux image. We're trying to connect to a Linux container running SQL Server on port 1433.
We're using unixODBC and FreeTDS, and everything works when creating a local network (`docker network create --driver bridge --subnet 172.21.0.0/24 our_network.bridge`), then adding the containers to the network. Then we can access SQL Server's data source by name (`docker run -itd --network=our_network.bridge --name local-mssql microsoft/mssql`), local-mssql in this case.
We can `telnet 127.0.0.1 1433`, so the port is open. But using unixODBC command line tool isql (parameters: server name, username, password), this is the result:
<span>+ isql -v sqlserver sa supersecret<br></span><span>[ISQL]ERROR: Could not SQLConnect<br></span><span>[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source<br></span><span>[01000][unixODBC][FreeTDS][SQL Server]Unknown host machine name.</span>
Any idea how we can access to our database?