Hi I just upgraded to bitbucket 5.5 and when running service I'm receiving following alert, any advice, I don't want my files or server insecure:
Starting Atlassian Bitbucket as dedicated user atlbitbucket
-bash: line 20: cd: /root: Permission denied
Starting bundled Elasticsearch
Hint: Run start-bitbucket.sh --no-search to skip starting Elasticsearch
Bundled Elasticsearch started successfully
Bitbucket is being run with a umask that contains potentially unsafe settings.
The following issues were found with the mask "u=rwx,g=rwx,o=rx" (0002):
- Access is allowed to 'others'. It is recommended that 'others' be denied
all access for security reasons.
- Write access is allowed to 'group'. It is recommend that 'group' be
denied write access. Read access to a restricted group is recommended
to allow access to the logs.
The recommended umask for Bitbucket is "u=,g=w,o=rwx" (0027) and can be
configured in _start-webapp.sh