I'm testing upgrading v5.9.14 to v6.4.1 to no avail. Any hints why the SQL error is triggered?
Hey Thomas,
The index s_lspacekey_idx is being introduced from Confluence 5.10 onwards so when the Confluence 6.4 upgrade trying to drop it, it will fail (as the index does not exist).
try this upgrade path: 5.9.14 > 5.10.8 > 6.4.1this should be alright.
Note: You'll need to rollback to the working 5.9.14 first before upgrading again.
Shouldn't this be mentioned and highlighted in the Upgrade notes? The fact that the upgrade path from 5.x to 6.x is not direct, is not mentioned anywhere in the documentation, as far as I looked.
The documentation is still incorrect. Please change the Upgrade Path section of the latest documentation. It currently says If your version is 5.0 to 6.x, "upgrade directly to the latest version". We tried that last week and and it failed because of this issue. https://confluence.atlassian.com/doc/upgrading-confluence-4578.html#UpgradingConfluence-1.Determineyourupgradepath
Three years later, it looks like there is no intention to update this.
It looks like you're new here. Sign in or register to get started.